questions utilisations umap

Entraide, partage, cartes personnalisées remarques... c'est par ici !
Répondre
bcroz
Messages : 7
Inscription : lun. juin 30, 2014 4:54 pm

questions utilisations umap

Message par bcroz » mar. juil. 01, 2014 2:19 pm

Bonjour ! :)

Je viens de créer ma carte, et j'en suis aux premiers tâtonnements... Après plusieurs heures, je me décide enfin à poser mes deux questions !
1. Pourquoi, après avoir enregistré, le panneau latéral visualiseur de données se referme-t-il alors que j'ai coché la case correspondante dans les propriétés avancées ?
(2. Une fois que j'ajoute un élément et que j'enregistre, comment faut-il faire pour contrôler le résultat ? : problème résolu : mon navigateur me jouait des tours)
Merci d'avance de votre aide ! :)

EDIT : :shock: on dirait une poule qui découvre une fourchette !!! J'ai l'habitude de mettre le nez dans le code (html et un peu php), mais là, je suis complètement décontenancée, il y a une logique que je ne comprends pas...
Par exemple, pour mettre une image, il y a cette indication :
Image: {{http://image.url.com}}
Image avec largeur (en pixels): {{http://image.url.com|largeur}}

Je mets donc l'url de l'image entre les {{ }}, et c'est bon.
Mais mon image apparaît petite (300px environ, elle en fait 500 en réalité). Comment fait-on pour augmenter la largeur ? Parce que si je rajoute |500px derrière l'url, ça ne marche plus ! Est-ce que le | a une signification particulière ? Ou faut-il agir ailleurs en parallèle ?
Merci de vos lumières !

ybon
Messages : 38
Inscription : mer. juin 18, 2014 7:40 pm

Re: questions utilisations umap

Message par ybon » jeu. juil. 03, 2014 3:02 pm

Bonjour bcroz, est-ce que je peux avoir un lien vers la carte en question, histoire de jeter un œil?

ybon
Messages : 38
Inscription : mer. juin 18, 2014 7:40 pm

Re: questions utilisations umap

Message par ybon » jeu. juil. 03, 2014 5:23 pm

Au passage, il ne faut pas mettre "px", donc seulement "|500", donc c'est peut-être ça qui pose problème.
Je vais tâcher de rendre ça plus clair et/ou plus tolérant.

bcroz
Messages : 7
Inscription : lun. juin 30, 2014 4:54 pm

Re: questions utilisations umap

Message par bcroz » jeu. juil. 03, 2014 5:52 pm

C'était ça, il ne faut pas mettre px !!! J'avais essayé plein de choses, mais pas ça ! :) Un problème résolu donc. Merci ! :)
(désolé, mais j'avais retiré toutes les images, je viens d'en remettre une sur l'épingle rouge, la plus à l'ouest).

Et pour le panneau latéral qui se referme alors que j'ai coché... L'erreur vient-elle de moi ?

ybon
Messages : 38
Inscription : mer. juin 18, 2014 7:40 pm

Re: questions utilisations umap

Message par ybon » jeu. juil. 03, 2014 7:42 pm

Et pour le panneau latéral qui se referme alors que j'ai coché... L'erreur vient-elle de moi ?
Le paramètre indique que le panneau latéral sera ouvert par défaut au chargement, mais ensuite l'utilisateur peut choisir de le fermer. De même quand tu édites la carte.

bcroz
Messages : 7
Inscription : lun. juin 30, 2014 4:54 pm

Re: questions utilisations umap

Message par bcroz » ven. juil. 04, 2014 8:32 am

ok, compris pour le panneau !

Puisque je t'ai sous le clavier, je me permets une autre question.
J'envisage de me servir de ton formidable outil pour réaliser une carte à base de photos, et ce serait bien qu'on puisse cliquer directement sur l'image. Je pense à ça car je n'ai pas de texte particulier à mettre sous les images, et donc afficher l'URL ou Cliquez ici, je me dis que c'est pas terrible ! Tu penses que c'est possible ?
Merci encore pour tout ça ! :)

ybon
Messages : 38
Inscription : mer. juin 18, 2014 7:40 pm

Re: questions utilisations umap

Message par ybon » jeu. juil. 17, 2014 4:16 pm

J'envisage de me servir de ton formidable outil pour réaliser une carte à base de photos, et ce serait bien qu'on puisse cliquer directement sur l'image. Je pense à ça car je n'ai pas de texte particulier à mettre sous les images, et donc afficher l'URL ou Cliquez ici, je me dis que c'est pas terrible ! Tu penses que c'est possible ?
Pas en l'état, mais je note dans un coin. :)

bcroz
Messages : 7
Inscription : lun. juin 30, 2014 4:54 pm

Re: questions utilisations umap

Message par bcroz » jeu. juil. 17, 2014 4:50 pm

Je note que tu le notes ! :)
Et je rajoute quelque chose, puisque ça a un rapport avec le lien, ce sera peut-être possible en même temps : quand on clique sur un lien dans la description, ça ouvre un onglet à chaque fois, ce serait plus logique que l'ouverture se fasse dans le même onglet ; ou alors dans un 2e si tous les autres liens que l'on va ouvrir se font dans ce 2e : car un onglet à chaque clic, on est vite encombré !

Avatar de l’utilisateur
cquest
Messages : 1929
Inscription : ven. avr. 16, 2010 12:22 am
Localisation : Val de Marne
Contact :

Re: questions utilisations umap

Message par cquest » jeu. juil. 17, 2014 6:56 pm

+1 surtout quand le lien est vers la même carte uMAp (exemple ma "visite guidée du rendu FR" qui depuis quelques temps ouvre plein d'onglets).

ybon
Messages : 38
Inscription : mer. juin 18, 2014 7:40 pm

Re: questions utilisations umap

Message par ybon » ven. juil. 18, 2014 5:34 pm

Utilisez des liens relatifs, ça ouvrira dans le même onglet.

bribri
Messages : 15
Inscription : mar. juil. 21, 2015 3:23 pm

Re: questions utilisations umap

Message par bribri » ven. oct. 23, 2015 10:44 am

Bonjour,

Je remonte ce sujet car je me penche à nouveau sur le problème.
Et je ne comprends pas cette histoire de relatif dans ce cas précis...
Ce que je comprends par lien relatif, c'est relatif à mon site, par exemple : <a href="../repertoire/page.php">
Mais là, la carte est dans une iframe dont la source est : src="http://umap.openstreetmap.fr/fr/map/..."
donc si, sur cette carte, je mets un lien du genre <a href="../repertoire/page.php"> ça renvoie vers le site umap.openstreetmap.fr qui n'a évidemment pas ma page.php ! :shock:
Oui ? Non ?
Si faire des liens relatifs est le seul moyen de faire en sorte qu'ils s'ouvrent tous dans la même fenêtre, je voudrais bien pourvoir y arriver !
Merci d'avance à qui pourra éclairer ma lanterne ! :)

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités