frame uMap ne s'affiche pas

Entraide, partage, cartes personnalisées remarques... c'est par ici !
-Steph-
Messages : 3
Inscription : sam. sept. 15, 2018 7:11 pm

frame uMap ne s'affiche pas

Message par -Steph- » mar. sept. 18, 2018 8:17 pm

Bonsoir,

Je suis en train de concevoir le site département d'un syndicat (wordpress, thème twenty-seventeen).
Sur ma page contact, j'ai d'abord intégré une carte openstreetmap avec le code suivant :

Code : Tout sélectionner

<iframe style="border: 1px solid black;" src="https://www.openstreetmap.org/export/embed.html?bbox=-1.688203811645508%2C48.11417568034556%2C-1.6848510503768923%2C48.11665404972984&amp;layer=mapnik&amp;marker=48.11541487998085%2C-1.6865301132202148" width="595" height="490" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
<small><a href="https://www.openstreetmap.org/?mlat=48.11541&amp;mlon=-1.68653#map=18/48.11541/-1.68653">Afficher une carte plus grande </a></small><strong><span style="text-decoration: underline;">
</span></strong></p>
Nickel, jolie carte qui s'affiche bien.

Je me suis ensuite dit que ce serait plus sympa de faire une carte personnalisée avec, en particulier, le logo du syndicat plutôt qu'une simple épingle. J'ai donc utilisé uMap.

Le code suivant ne semble pas fonctionner, on ne voit qu'un cadre vide :

Code : Tout sélectionner

<iframe style="border: 1px solid black;" src="http://umap.openstreetmap.fr/fr/map/snfolc35_247954?scaleControl=false&miniMap=false&scrollWheelZoom=false&zoomControl=true&allowEdit=false&moreControl=true&searchControl=null&tilelayersControl=null&embedControl=null&datalayersControl=true&onLoadPanel=undefined&captionBar=false" width="595" height="490" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
<small><a href="https://www.openstreetmap.org/?mlat=48.11541&amp;mlon=-1.68653#map=18/48.11541/-1.68653">Afficher une carte plus grande </a></small><strong><span style="text-decoration: underline;">
Quelqu'un saurait-il pourquoi ma carte uMap ne s'affiche pas ?

Merci d'avance pour vos réponses.

Cartograf
Messages : 101
Inscription : lun. juil. 11, 2016 12:12 pm

Re: frame uMap ne s'affiche pas

Message par Cartograf » ven. sept. 21, 2018 4:22 pm

<iframe style="border: 1px solid black;" src="http://umap.openstreetmap.fr/fr/map/snfolc35_247954?scaleControl=false&miniMap=false&scrollWheelZoom=false&zoomControl=true&allowEdit=false&moreControl=true&searchControl=null&tilelayersControl=null&embedControl=null&datalayersControl=true&onLoadPanel=undefined&captionBar=false" width="595px" height="490px" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
<small><a href="https://www.openstreetmap.org/?mlat=48. ... 1/-1.68653">Afficher une carte plus grande </a></small><strong><span style="text-decoration: underline;">


? (je ne sais pas si cela pouvait provoquer ton problème d'affichage)

Essai avec ce code :

Code : Tout sélectionner

<iframe width="595px" height="490px" frameBorder="0" allowfullscreen src="https://umap.openstreetmap.fr/fr/map/snfolc35_247954?scaleControl=false&miniMap=false&scrollWheelZoom=false&zoomControl=true&allowEdit=false&moreControl=true&searchControl=null&tilelayersControl=null&embedControl=null&datalayersControl=true&onLoadPanel=undefined&captionBar=false"></iframe><p><a href="https://umap.openstreetmap.fr/fr/map/snfolc35_247954">Voir en plein écran</a></p>
Et tu as raison ; c'est plus sympa avec un petit logo qu'une épingle seul.
Bon courage à vous, et je nous espère pour tous (enfin) un monde bien meilleur et plus juste un jour.

Cartograf
Messages : 101
Inscription : lun. juil. 11, 2016 12:12 pm

Re: frame uMap ne s'affiche pas

Message par Cartograf » ven. sept. 21, 2018 4:35 pm

Pour récupérer ton code pour intégrer ta carte uMap, tu as un bouton dédié : exporter et partager la carte.
En cliquant dessus, le volet "Intégrer la carte dans une iframe" s'ouvre :
Tu paramètres ce que tu veux qui s'affiche ou non (en bas, sous "Options d'export de l'iframe" via les boutons)
Pendant que tu procèdes, le code à récupérer s'actualise.
A l'issu tu le copie colle.

deuzeffe
Messages : 51
Inscription : jeu. déc. 28, 2017 5:39 pm

Re: frame uMap ne s'affiche pas

Message par deuzeffe » ven. sept. 21, 2018 7:51 pm

Mélange http et https ?

-Steph-
Messages : 3
Inscription : sam. sept. 15, 2018 7:11 pm

Re: frame uMap ne s'affiche pas

Message par -Steph- » ven. sept. 21, 2018 10:17 pm

Bonsoir à tous,

Merci beaucoup pour vos réponses.

Déjà, comme bêtement j'étais sur uMap en http, le code généré par uMap était aussi en simple http. J'ai donc corrigé.

Cela résout en partie le problème mais en partie seulement.

Voici le code actuellement généré par uMap en utilisant la manip indiquée par Cartograf (qui était déjà celle que j'utilisais sauf que j'avais un peu personnalisé) :

Code : Tout sélectionner

<iframe width="100%" height="300px" frameBorder="0" allowfullscreen src="https://umap.openstreetmap.fr/fr/map/snfolc35_247954?scaleControl=false&miniMap=false&scrollWheelZoom=false&zoomControl=true&allowEdit=false&moreControl=true&searchControl=null&tilelayersControl=null&embedControl=null&datalayersControl=true&onLoadPanel=undefined&captionBar=false"></iframe><p><a href="https://umap.openstreetmap.fr/fr/map/snfolc35_247954">Voir en plein écran</a></p>
Si je le colle tel quel, cela fonctionne sous chrome et sur mon android.

Par contre, sous firefox l'iframe n'apparaît toujours pas... (je précise que j'ai vidé et revidé le cache de mon navigateur et celui de mon site).

:shock:

deuzeffe
Messages : 51
Inscription : jeu. déc. 28, 2017 5:39 pm

Re: frame uMap ne s'affiche pas

Message par deuzeffe » ven. sept. 21, 2018 11:22 pm

Et du côté des ad- et tracker-blockers ? Par ex. Privacy Badger bloque umap (oui, c'est très con). Sous FF, F12 et regarder ce que raconte la console. Peut aussi être dû à la nouvelle politique de sécurité de FF (quelle version ?) Bidouiller du côté du cadenas dans la barre d'adresse pour désactiver temporairement la navigation dite sécurisée et voir ce que ça donne.

Cartograf
Messages : 101
Inscription : lun. juil. 11, 2016 12:12 pm

Re: frame uMap ne s'affiche pas

Message par Cartograf » sam. sept. 22, 2018 12:31 am

Oui, ou un ad-on du type "no-script"
Je viens d'essayer tes deux codes et le miens (sous Firefox) et tous s'affichent bien sur ma machine (sous linux).

-Steph-
Messages : 3
Inscription : sam. sept. 15, 2018 7:11 pm

Re: frame uMap ne s'affiche pas

Message par -Steph- » sam. sept. 22, 2018 6:25 am

Vous êtes des chefs !!! :)

C'était Privacy badger qui bloquait ma frame !
uMap-tracers.png
uMap-tracers.png (23.27 Kio) Consulté 85 fois
Je suis surprise quand même, les fonts google ne me tracent pas mais uMap si...

En tous cas, un grand merci à tous !!!

deuzeffe
Messages : 51
Inscription : jeu. déc. 28, 2017 5:39 pm

Re: frame uMap ne s'affiche pas

Message par deuzeffe » sam. sept. 22, 2018 11:12 am

Il me semble que le surblocage d'umap a été signalé à qui de droit (ou peu s'en faut : https://github.com/umap-project/umap/issues/628 ).

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité