Problème d'affichage... donc de vérification

Quels outils, GPS, tags, méthodes, techniques utiliser pour rentrer des données.
Traduction des tags
Avatar de l’utilisateur
Captain47
Messages : 104
Inscription : ven. sept. 02, 2016 5:29 pm

Problème d'affichage... donc de vérification

Message par Captain47 » mer. juin 07, 2017 6:10 pm

Bonjour,

Je viens il y a peu de «créer» une île au confluent du Lot et de la Garonne (https://www.openstreetmap.org/way/498497122) Or, elle n'apparaît toujours pas sur OSM. Pour info, je l'ai mis en inner dans la relation avec la riverbank. J'ai dû faire une erreur quelque part, mais ne sais où.

Quelqu'un pourrait-il jeter un œil, le récupérer ensuite avant de me dire où est mon erreur afin que dans l'avenir si je suis confronté au même problème je ne me plante pas et permette à OSM de ressembler au mieux au terrain... Et bien sûr que je corrige mon erreur...

Merci d'avance, cordialement
Un Captain attaché au Libre

Avatar de l’utilisateur
Lenny
Messages : 47
Inscription : jeu. janv. 17, 2013 7:37 pm

Re: Problème d'affichage... donc de vérification

Message par Lenny » ven. juin 09, 2017 12:35 am

Bonsoir
Peut-être un problème d'affichage ? ou de rafraichissement ?

J'ai trouvé un cas similaire au tien qui s’affiche correctement http://www.openstreetmap.org/way/332512597 les trois ilots sont affichés.

La seule différence me semble être le tag "place" qui sur le wiki ne semble pas être nécessaire s'il n'y a pas de "name" mais je ne vois pas pourquoi cela gênerait.

Il y a le même non-affichage sur http://tile.openstreetmap.fr/?zoom=18&l ... 0000FFFFFF

cordialement
Leni

Avatar de l’utilisateur
Captain47
Messages : 104
Inscription : ven. sept. 02, 2016 5:29 pm

Re: Problème d'affichage... donc de vérification

Message par Captain47 » ven. juin 09, 2017 11:03 am

Lenny a écrit :
ven. juin 09, 2017 12:35 am
La seule différence me semble être le tag "place" qui sur le wiki ne semble pas être nécessaire s'il n'y a pas de "name" mais je ne vois pas pourquoi cela gênerait.
Bonjour,

Dans le doute je viens de retirer l'étiquette "place=island". Pour l'instant rien de neuf, mais attendons un peu le rafraîchissement d'OSM pour voir si ça marche... Peut-être que "island" ne fonctionne-t'il qu'avec un trait de côte et non une berge...
Un Captain attaché au Libre

JBosm
Messages : 67
Inscription : lun. avr. 22, 2013 12:43 pm

Re: Problème d'affichage... donc de vérification

Message par JBosm » ven. juin 09, 2017 2:48 pm

Ben… vue la taille de la relation riverbank (https://www.openstreetmap.org/relation/1155338), je pense que si elle n'apparait pas, à part allumer un cierge, il n'y a pas grand chose à faire… Éventuellement se motiver pour la redécouper en morceaux à taille humaine.
Il me semblait avoir lu quelque part que Mapnik (ou était-ce le calcul de tuiles périmées ou Postgis ?) ne savait pas gérer correctement les éléments de cette taille-là.

Avatar de l’utilisateur
Captain47
Messages : 104
Inscription : ven. sept. 02, 2016 5:29 pm

Re: Problème d'affichage... donc de vérification

Message par Captain47 » ven. juin 09, 2017 6:29 pm

JBosm a écrit :
ven. juin 09, 2017 2:48 pm
Ben… vue la taille de la relation riverbank (…) Éventuellement se motiver pour la redécouper en morceaux à taille humaine.
Je n'avais peut-être pas tort de lancer cette discussion (utilité des riverbanks) - viewtopic.php?f=2&t=5995 - où je proposais de les découper à la taille de la commune sur laquelle on travaille... Je vais essayer de le faire sur cette commune et voir si le problème se solutionne...

Par contre si on découpe par commune, cela peut nécessiter de les regrouper dans une relation... La même que celle du fleuve ou une spécifique ?
Un Captain attaché au Libre

Avatar de l’utilisateur
Captain47
Messages : 104
Inscription : ven. sept. 02, 2016 5:29 pm

Re: Problème d'affichage... donc de vérification

Message par Captain47 » sam. juin 10, 2017 7:12 am

GAGNÉ !!! :P

Je viens de redécouper la riverbank à la taille de la commune de Monheurt et de supprimer, au passage, un doublon de relation dans la riverbank de la Garonne et cela marche. Affichage instantané...

Moralité découpez vos berges "à taille humaine" et tout ira pour le mieux...
Un Captain attaché au Libre

Avatar de l’utilisateur
Lenny
Messages : 47
Inscription : jeu. janv. 17, 2013 7:37 pm

Re: Problème d'affichage... donc de vérification

Message par Lenny » sam. juin 10, 2017 12:06 pm

BRAVO !
elle apparait sur openstreetmap, mais pas encore sur tile (j'ai fait un /dirty pour voir si elle arrive ...

cordialement
Leni

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 15 invités