Page 1 sur 1

Qgis et caractères accentués shapefile osm

Publié : ven. janv. 02, 2015 10:55 pm
par Kalaallit Nunaat
Bonjour,
A propos de QGIS, comment faire pour ne plus avoir de hiéroglyphes à la place des accents? Y-at-il une police spéciale à utiliser?
J'ai le problème avec les noms des communes issues du fichier shp 5m de https://www.data.gouv.fr/fr/datasets/de ... streetmap/
Merci.

Re: Qgis et OSM

Publié : sam. janv. 03, 2015 1:03 am
par cquest
Les premières versions de ces exports avaient un problème d'encodage (donc un problème dans les fichiers et pas dans QGis).
C'est bien sur la dernière version (celle du 1/1/2015) que tu rencontre un problème ?

Re: Qgis et OSM

Publié : sam. janv. 03, 2015 7:55 am
par Kalaallit Nunaat
Oui tout à fait, sur la dernière version du 01 janvier.

Mais j'ai le même problème avec les étiquettes des rues résidentielles issues d'OSM et extraites avec Quick OSM, et c'est même pire ! 6 lettres bizarres pour une voyelle à accent :shock:

Re: Qgis et OSM

Publié : sam. janv. 03, 2015 10:35 am
par cquest
Je viens d'ouvrir un des fichiers exportés la 1/1/2015 et aucun problème d'accent pour moi dans QGis. Il y a donc un problème dans ta config de QGis...

Re: Qgis et OSM

Publié : sam. janv. 03, 2015 4:51 pm
par Kalaallit Nunaat
Ok! c'est bien ce qu'il me semblait, maintenant comme je ne suis pas informaticien pour 2 sous... :roll: je vais fouiller la notice

Bon en tout cas, Quick OSM fonctionne parfaitement, et je suis sous Windows 8 - 64 bits.

Re: Qgis et OSM

Publié : sam. janv. 03, 2015 11:41 pm
par Sefoun
Quand tu ouvres un shapefile tu peux choisir l'encodage normalement, par défaut c'est celui du système qui doit être sélectionné sauf si tu as modifié ça dans les configurations. Si tes "hiéroglyphes" apparaissent avec le codage système essaie avec l'UTF-8 par exemple.

Re: Qgis et OSM

Publié : dim. janv. 04, 2015 10:59 am
par cquest
Ce qui est étonnant, c'est que dans le fichier shapefile cité en exemple (limites de communes OSM dispo sur data.gouv.fr) il y a un fichier .cpg justement destiné à indiqué l'encodage utilisé pour le texte. Celui-ci indique bien que c'est de l'UTF-8.

Re: Qgis et OSM

Publié : dim. janv. 04, 2015 2:34 pm
par Kalaallit Nunaat
J'ai bien trouvé une fenêtre :
Propriétés de la couche - Infos -Encodage des données source
mais il n'y a rien dans le menu déroulant et on ne peut rien y écrire... :?

Re: Qgis et OSM

Publié : dim. janv. 04, 2015 6:33 pm
par Sefoun
Je viens de faire le test avec les mêmes données, de base le codage est sur système, et donc à l'ouverture du fichier les noms avec des accents s'affichent aussi avec des caractères bizarres. Par contre en modifiant l'encodage sur UTF-8 dans les propriétés de la couche, le problème se résout.

Par contre si tu n'a rien dans le menu déroulant sur l'encodage des données sources, c'est peut être dû à un soucis lors de l'installation. Au lieu de chercher des heures une solution à ce problème très spécifique, à ta place je ré-installerais Qgis.

Re: Qgis et OSM

Publié : lun. janv. 05, 2015 6:44 pm
par Kalaallit Nunaat
Gustry a écrit :Il y a du squattage de topic ;)

Pour répondre à la questions des accents, j'ai déjà rencontré des problèmes sous Windows.
De mémoire, j'ai eu le soucis aussi en ouvrant le shapefile de datagouv avec QGIS (ou un shapefile de QuickOSM en UTF-8 eux aussi) sous Windows.
Je me suis rassuré que cela ne venait pas de QGIS quand j'ai testé avec ArcGIS, même problème !
Donc cela vient plus du système avec les shapefile.

Je me demande si il faut pas essayer le CP-1252 :
http://www.geoinformations.developpemen ... 5b3841.odt
pour des shape avec windows ? Cquest ?

QuickOSM a un ticket très semblable avec les accents sous Windows :
https://github.com/3liz/QgisQuickOSMPlugin/issues/39
Désolé pour le squat, mais comme j'ai vu marqué Qgis et OSM je me suis dit que c'était là ! je ne suis pas vraiment hors sujet ;)
Bon y a du mieux j'ai les étiquettes qui vont bien pour les noms des communes du fichier datagouv et ceci grâce au très bon tuto ci-dessus, merci !
J'ai réussi en décochant : Ignorer la déclaration interne d'encodage des shapefiles dans Préférences - Options - Source de données - Gestion des sources de données. puis dans : Ajouter une couche vecteur j'ai affiché ISO-8859-1

Il reste que les données issues d'OSM grâce à Quick OSM, ben! ça veut pas aller aussi bien, j'ai toujours des hiéroglyphes ! :(
J'imagine que ce doit être la même procédure, mais y a un truc qui m'échappe encore!

En tout cas QGIS c'est top ! bon j'en maîtrise qu'un tout petit bout, mais je vais apprendre...

Merci pour votre aide.

Re: Qgis et caractères accentués shapefile osm

Publié : sam. janv. 17, 2015 7:13 pm
par sly
Pour info, j'ai séparé le sujet en deux pour avoir ici, l'affichage des lettres accentuées dans qgis suite à l'ouverture d'un shp, et de l'autre le bug en utilisant le pluging QuickOSM

Noter qu'il existe un sous forum pour umap et un autre pour osmand, après tout, Qgis, de plus en plus utilisé avec des données OSM pourrait justifier un nouveau sous-forum

Re: Qgis et caractères accentués shapefile osm

Publié : mer. mars 25, 2015 2:57 pm
par SHENZHU
Salut

j'avais le meme souci. Guidé par les avis du fil, je me suis rendu dans les propriétés de la couche en question, onglet General, Section info, champs "Encodage des données sources". Mon encodage était UTF8... Ce qui à priori, à ma connaissance, aurait du fonctionner. J'ai essayé avec systême, et desormais tout est rentré dans l'ordre

Re: Qgis et caractères accentués shapefile osm

Publié : jeu. juil. 23, 2015 3:40 pm
par bmaranges
Bonjour,
j'ai rencontré le même problème.

Menu Préférences
options
Sources de données : décocher "Ignorer la déclaration interne d'encodage des shapefiles"
Pour moi ça a fonctionné... :)
Cordialement,