Accès aux tuiles bloqué?

Bonjour nous débutons dans le domaine, nous sommes en cour de création d’une application Android pour utiliser les tuiles de openstreetmap.fr
Est-ce possible que notre application soit bloqué car nous n’arrivons plus à obtenir les tuiles?
Quels sont les limitation d’utilisation des tuiles?
Merci

Quelle URL d’accès aux tuiles est utilisée (pour savoir qui gère ça) ?

Quelle IP ou referer de votre côté ?

Quel symptôme exact ?

Merci pour la réponse rapide, nous utilisons un composant Brutile pour obtenir les tuiles avec une des adresses:
https://a.tile.openstreetmap.fr/osmfr/{z}/{x}/{y}.png ou
https://b.tile.openstreetmap.fr/osmfr/{z}/{x}/{y}.png ou
https://c.tile.openstreetmap.fr/osmfr/{z}/{x}/{y}.png
Je ne crois pas que l’IP soit problématique car nous utilisons une seconde application de test qui réussis à obtenir les tuiles en utilisant le même composant aux mêmes adresse.
Est-ce qu’une application peut être bloquée car nous ne contrôlons pas les requêtes effectuée par le composant?

Ok, donc ce sont bien les serveurs OSM-FR qui répondent, et je les administre.

Il y a peu de blocages faits, ils visent essentiellement les téléchargement en masse, pas spécifiquement telle ou telle appli.

Il me faudrait plus d’éléments pour comprendre, regarder dans les logs au autre, par exemple:

  • le referer,
  • le user-agent,
  • les IP sur lesquelles vous avez constaté des blocages (même si c’est pas un blocage par IP, ça permet de fouiller les logs).

Quelle erreur rencontrez-vous ?
Une réponse HTTP avec erreur ?
Une impossibilité d’établir la connexion TCP ? Quelle erreur…
Un problème HTTPS (nous utilisons Letsencrypt, donc l’échéance du 30/9 vous/nous impacte peut-être)

Bref, besoin de détails !

Pouvez-vous me donner de plus amples détails sur le Referer et le User-Agent que nous devrions utiliser?

Concernant les erreur HTTP ou les erreurs de connexion, le composant que nous utilisons ne semble pas donner les erreurs. Nous sommes en investigation afin de trouver comment obtenir les messages d’erreurs.

Merci pour les précision!

Pas de valeur particulière à utiliser pour les champs referer et user-agent, j’en ai juste besoin pour fouiller les logs.

A propos du user-agent… https://github.com/BruTile/BruTile/blob/master/BruTile/Web/HttpTileSource.cs#L30

Sans plus d’info, je ne peux pas regarder ce qui cloche dans un log quotidien d’environ 20 million de lignes.

Ah oui… fort probable que sans referer (probable si c’est une appli non web) ni user-agent, le serveur refuse de répondre aux requêtes.

Nous avons trouvés le problème.

C’était relié à une configuration du client HTTP et de la configuration SSL du projet en tant que tel.

De plus nous avons ajoutés le Referer un le UserAgent afin de nous assurer de ne pas nous faire bloquer.

Merci de nous avoir aidés à trouver la solution en nous permettant d’éliminer les causes possible de problèmes!

Peut-on connaitre les referer et user-agent utilisés ? Juste pour faire le lien avec un pseudo sur un forum…