ENEDIS : pas d'affichage sur ID

La source Enedis est proposée sur ID mais son affichage reste noir. Une explication ?

Je pense qu’il n’y a pour le moment les orthophotos que du côté d’Avignon.

Sur enedis.openstreetmap.fr en affichant les orthophotos et en dezoomant, il y a qu’à Avignon qu’il y a des données.

Peux-tu confirmer que si tu vas sur la zone d’Avignon tu as des photos ? Dans ce cas le problème ne viendrait pas d’ID mais du fond Enedis.

Voilà le cadrage sur la zone commerciale, sur le site il y a bien une vue disponible (commune d’Orange) mais pas sur ID.

Salut,
je viens de jeter un œil et il semblerait que ça soit un blocage technique : les tuiles du fond carte Enedis ne sont pas autorisées à être utilisées sur https://openstreetmap.org, seulement sur https://enedis.openstreetmap.fr.

Pour entrer dans les détails :
https://wms.openstreetmap.fr/tms/1.0.0/enedis/{z}/{x}/{y} attend la valeur (http|https)://enedis.openstreetmap.fr pour le header Referer, sinon il retourne une 403.

Il semble qu’il y ait un changement à faire du coté du serveur de tuiles pour autoriser https://openstreetmap.org. Je ne sais pas encore où ça se passe ni si c’est open-source.

1 Like

@InfosReseaux effectivement ce serait bien. Car passer par un seul type d’éditeur me parait peu fructueux.

Bonjour

Effectivement c’est une condition de la convention passées avec Enedis : les images ne sont accessibles que dans les éditeurs OSM.

Il y a bien une limitation sur le referer, @cquest ou @Jocelyn doivent pouvoir faire le nécessaire pour que ca fonctionne dans iD je crois ?

On est bien d’accord que ID est toujours un éditeur OSM :wink: ?

Oui, tous les referer de l’écosystème n’ont simplement pas été ajoutés à la liste

Je soupçonne qui y a eu des reflexes de référencements liés à l’usage.