How to stop OpenWebStart/JOSM from prompting to make shortcuts on every launch?

So I’ve just started to use JOSM in the past couple weeks, and there’s a behavior that’s just mildly annoying enough for me to ask about. I’ve installed it on several Windows computers (a few Windows 10, one Windows 11, which should all be generally up-to-date) by installing OpenWebStart 64-bit, and running the josm.jnlp download. This works pretty well, actually, but every single time I launch it (whether from the jnlp file, or from the shortcut created in my Start Menu) it asks me again whether I want to create shortcuts to it. On the first launch it makes perfect sense to ask me and I found rather convenient, but once I already have the shortcut in my Start Menu and that’s how I launched it, it seems rather weird to be asking again.

So I need to uncheck those boxes and click the “Ok” each time I want to run it. It’s certainly just a mild annoyance, but it seems like it shouldn’t be needed, so I thought I might have something set up wrong or misconfigured. (It’s even more annoying on my slower computers where I want to do other things while it’s starting up, and I need to go find the dialog buried under other windows.)

3 posts - 2 participants

Read full topic

Ce sujet de discussion accompagne la publication sur