importer les donnees osm dans postgresql

svp bonjour quelquon pourrait t-il me donner la procedure pour introduir les donnees osm.pbf que jai telecharger pour mettre dans ma BD jai essayer cette commande

osm2pgsql -K -c -s -d osm -U osm -W cameroon-lastest.osm.bz2

et je recois

Error: pg_wrapper: osm2pgsql was not found in /usr/lib/postgresql/9.4/bin

si cest possible dune autre maniere i am waiting for ur suggession
thanks

Bonsoir,
Tu ne semble pas disposer d’osm2pgsql sur ton poste. Pour l’installer, tu as de la documentation ici :
https://github.com/openstreetmap/osm2pgsql

vincent

merci pour ta reponse
ofet moi jutilise ubuntu et jai installe postgresql 9.4
juste pour la precision comment utiliser le lien que tu vien de me donner

Bonjour,
Tu as les instructions au début de cette page :
https://switch2osm.org/fr/servir-des-tuiles/mettre-en-place-manuellement-un-serveur-de-tuiles-14-04/

vincent

daccord merci je suis en cours d’installation et apres que dois je faire par la suite

Lire la doc :wink:
Le lien que je t’ai donné ( https://switch2osm.org/fr/servir-des-tuiles/mettre-en-place-manuellement-un-serveur-de-tuiles-14-04/ ) décrit aussi le chargement des données, il doit pouvoir répondre à ton problème initial (importer les données).

vincent

ok merci encore jusqu’ici je suivait la procedure et a un niveau ca buy en effet

./configure
         error : configure : required library not foung

comment faire pour ne plus afficher ca appriorie jai oublier une bibliotheque

Ça en inspirera peut-être d’autres, mais moi je ne vois pas. Il faudrait que tu donnes des éléments sur ta config et le déroulé des commandes qui précèdent. Tu n’as aucun message avant et/ou juste après celui là ?

vincent

switch2osm propose deux façons d’installer les outils, une manuelle (celle proposée par vdct) et une à partir de packages…

Je te recommande plutôt celle avec les packages: https://switch2osm.org/fr/servir-des-tuiles/construire-un-serveur-de-tuiles-depuis-des-paquets/

ça t’évitera les problèmes de librairies manquante ou autre nécessaire pour compiler les logiciels.

Le tuto est prévu pour ubuntu 14.04 LTS, version à préférer actuellement sur un serveur car maintenu à long terme (LTS).

dqccord ,erci de votre disponibilite je ,e deplace pour un voyage de 3 jours aussi tot revenue je vous recontacte encore merci chere a,i

ofet jai lu quelque part quil sagit dun probleme de variable denvironnement concernant ma tte premiere auestion au’en pensez vous.??
ofet jai deja telecharger les donnees et je veux les introduir dans ma BD il y a til dautres possibilite.?

Bonjour,
Fais-un effort de relecture avant de poster tes messages, ils sont quasiment illisibles.

Bonjour,

Je voulais savoir si vous aviez une documentation pour Windows par hasard aussi :smiley:
je demande au cas où parce que je bloque aussi pour importer les données sur postgresql.

Windows ?

“Écoute, on t’connaît pas, mais laisse nous t’dire que tu t’prépares des nuits blanches… des migraines… des “nervous breakdown”, comme on dit de nos jours.” (Raoul Volfoni)

Je blague à peine. La majorité des outils, scripts, tuto sont très orienté Linux. Les portages sous Windows ne fournissent pas un équivalent à 100% et bien moins de monde pourra t’aider (moi en tout cas je ne peux pas)… à toi de voir, c’est peut être le moment de switcher :wink:

^^ je pers pas espoir
Mais c’est vrai que je trouve pleins de renseignement pour Linux mais pas pour Windows. comme si c’était un monde inconnu.

Mais sinon(et oui l’invité s’est inscrite sur le forum ^^)
y faut que je trouve une alternative

À une époque, j’ai réussi à importer des données pbf dans une base pg sous W7…
J’avais gardé ces lignes de commande de coté au cas où, je te les donne sans garantie ni SAV, de mémoire, ça allait tout seul à partir de la fenêtre de commande (une fois pg et postgis installés, osm2pgql en place, étouétou) :
createdb -E utf8 -U postgres osm_new
psql -U postgres -d osm_new -f “C:\Program Files\PostgreSQL\9.3\share\contrib\postgis-2.1\postgis.sql”
psql -U postgres -d osm_new -f “C:\Program Files\PostgreSQL\9.3\share\contrib\postgis-2.1\spatial_ref_sys.sql”
psql -U postgres -d osm_new -f “C:\Program Files\PostgreSQL\9.3\share\contrib\postgis-2.1\legacy.sql”
osm2pgsql -U postgres -d osm_new -S C:/[…]/osm2pgsql/test.style C:/[…]data.osm.bz2

bonjour je suis de retour de vacance et le meme probleme reitere jaimerai savoir comment ajouter une variable d’environnement pour se logiciel osm2pgsql

@invité : tu utilises quel système d’exploitation ?

je travaille sur ubuntu 14.04 ces commande marchent telle sous ce systeme???

ça m’étonnerai… C: sous ubuntu ça va pas le faire :wink:

Si tu es sous ubuntu 14.04, le meilleur tuto est ici: https://switch2osm.org/fr/servir-des-tuiles/construire-un-serveur-de-tuiles-depuis-des-paquets/