Marker and Marker Colors

Hi, I am sorry, I might double the topic but my french is not so good to understand the french posts.
I made a map with the french umap and mapped already about a thousand sites. Unfortunately ultimately the markers disappeared, if I chose other symbols then the default ones. Since a few weeks I could not access my map anymore, and now that I can again the former markers seem to be gone. The former ones being white and bigger. Is there a way to regain the symbols, as I would otherwise have to go back and change about half of my markers manually to the current markers. Someone has any idea?
I tried to write the French Admin but haven’t received any notice so far.
Please help!

hi @Leo and welcome (bienvenue in French)

if you can, could you share url of your map ?
you can alo share it by message direct, if it isn’t public

Hi @vinber
Thank you for replying.
Lokal Mapping - uMap (short link)

@ybon @davidbgk

1 Like

I’ll have a look!

1 Like

Here again to show the problem with the markers. There are only the black symbols to choose from now, which are smaller than the symbols before.

Those images will become white if the icon color is « dark » enough.

I’m working on a way for you to easily retrieve images already used in the map.

1 Like

Bonjour, merci beaucoup pour ce super outil qu’est uMap! @ybon, serait-il par ailleurs possible d’ajouter un bouton dans les paramètres pour désactiver le changement de couleurs du centre de l’icône (dans les options d’interface par exemple)? Je m’étais fait un beau code couleur dégradé pour mes cartes qui marchait bien avec le blanc et elles ont maintenant l’air assez confuses…

Merci d’avance pour votre aide!

1 Like

Bonjour @MightyPotato

Est-ce qu’il serait possible de voir ce que ça donne sur la carte en question ? On essaye justement d’avoir des couleurs qui rendent les marqueurs accessibles au plus grand nombre en terme de contrastes et il est possible que l’on passe à côté de certains cas.

Bien sûr, la voici!

Les couleurs des points d’intérêt correspondent à la datation des bâtiments. Je vous concède que la carte n’est déjà pas hyper lisible à la base, mais le changement de couleur du centre ajoute à la confusion : on a l’impression qu’il y a deux grilles de lecture par point!

@ybon Please let us know, when there is a change and it is possible to use the white again. In my case it were the colors Tan, Grey and Silver that I previously used with white symbols. I understand the thing with the contrast and accessibility, but would be great to have the option to change it back to white. Just because so many people already worked with the old symbols before.

Thank you in advance!

@Leo it might be improved when feat: change breakpoint to switch black SVG img to white by yohanboniface · Pull Request #1593 · umap-project/umap · GitHub is deployed

@MightyPotato ça va être corrigé avec fix: make default picto always white for now by yohanboniface · Pull Request #1609 · umap-project/umap · GitHub qui force le rond en blanc

1 Like

Both changes are now live / les deux fix sont déployés

1 Like

Super, merci beaucoup!

Hi, weirdly now it says I dont have own maps anymore. If I click on the url I also cant edit anymore. I had the same problem some weeks ago. One day the editing symbol reappeared, but then the markers were different. Might that be, because the admins are changing something in the background?

Can you give more details ? Which page ? What’s your username ? How many maps you have ? Which provider you use for login (OSM…° ?

Sure. My username is Lokal Bau Werk, the map is Lokal Mapping - uMap. I only have this map. For login I use OSM.

humm, but can you explain in more details what is the issue ? Which URL, what you see, what you expect instead… ?

Sure. First of all it says now that I dont have own maps. Just a few days ago when I logged in, it showed me the map. If I go on the URL of the map the editing logo is missing in the right upper corner. So I can only view it.


Two days ago I was still able to edit, but as I wanted to see the changes, I was refreshing the page and the editing toolbar disappeared since then.

Can you share a screenshot of the dashboard page too ?

1 Like