Problem updating latest JOSM.exe in Windows 10

Hi

I’m having problems updating to the latest JOSM.exe in Windows 10.

I suspect this maybe a windows problem, but I’m hoping someone has had similar problems & will be aware of a solution.

I downloaded the JOSM.exe file from the JOSM website & tried to install in two ways:

  1. Double clicking on the .exe
  2. Right clicking & ‘running as administrator’

The first time I ran it both ways windows defender blocked it, but I clicked the ‘install anyway’ option.

It then displayed the ‘Please wait while windows configures JOSM’ dialog box. The green progress bar completed 3 or 4 times, but then the dialog disappeared and nothing else happened. This now occurs each time I click on it

I checked for minimized windows in the Taskbar & in Task Manager, but there were no install programs running.

Rebooting the PC made no difference.

I’ve tried a couple of older version of JOSM, but with the same problem.

The JOSM.msi version requires the removal of JOSM before installing. I’m unwilling to do that without a guarantee it’ll install correctly.

I’ve updated other programs recently, such as Notepad++ with no problems.

Ant ideas how to resolve this problem?

2 posts - 2 participants

Read full topic


Ce sujet de discussion accompagne la publication sur https://community.openstreetmap.org/t/problem-updating-latest-josm-exe-in-windows-10/107218